[Testing Update] 2019-08-12 – XFCE 4.14, LibreOffice 6.3, Kernels, LibInput 1.14, Haskell

@philm wrote:

Hello community,

I am happy to announce another Testing Update. Mostly we have XFCE 4.14, LibreOffice and Kernel updates with this one.

Update news

This update holds the following changes:

  • XFCE got updated to 4.14
  • LibreOffice is now at 6.3.0
  • Kernels got updated to their latest releases
  • libinput is now at 1.14.0
  • Latest haskell and upstream updates
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.70
  • linux44 4.4.189 (no legacy nvidia-340 module!)
  • linux49 4.9.189
  • linux414 4.14.138
  • linux419 4.19.66
  • linux51 5.1.21 [EOL]
  • linux52 5.2.8 (no catalyst module!)
  • linux53 5.3-rc4 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt16

Package Updates (Mon Aug 12 07:23:23 CEST 2019)

  • testing community x86_64: 97 new and 97 removed package(s)
  • testing core x86_64: 8 new and 8 removed package(s)
  • testing extra x86_64: 199 new and 88 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-11           2019-08-12
-------------------------------------------------------------------------------
                            libcpuid 0.4.1.r15.g88d98ce-1 0.4.1.r18.gf6e4e23-1
                         mint-themes              1.8.1-1              1.8.2-1
                              octopi             0.9.0-13             0.9.0-14
          octopi-notifier-frameworks             0.9.0-13             0.9.0-14
                 octopi-notifier-qt5             0.9.0-13             0.9.0-14


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-11           2019-08-12
-------------------------------------------------------------------------------
                                agda           2.6.0.1-15           2.6.0.1-16
                         amavisd-new             2.11.0-7             2.12.0-1
                                c2hs            0.28.6-43            0.28.6-44
                       cabal-install          2.4.0.0-121          2.4.0.0-122
                               cgrep           6.6.25-158           6.6.25-159
                               chafa              1.0.1-1              1.2.0-1
                               darcs            2.14.2-91            2.14.2-92
                                dart              2.4.0-1              2.4.1-1
                           git-annex         7.20190730-6         7.20190730-7
                          git-repair        1.20170626-79        1.20170626-80
                haskell-authenticate            1.3.4-323            1.3.4-324
                         haskell-aws            0.21.1-77            0.21.1-78
                  haskell-cheapskate           0.1.1.1-77           0.1.1.1-78
                haskell-configurator           0.3.0.0-87           0.3.0.0-88
                   haskell-criterion           1.5.5.0-46           1.5.5.0-47
                   haskell-esqueleto              3.1.0-1              3.1.0-2
                 haskell-fast-logger             2.4.16-9            2.4.16-10
                   haskell-filemanip           0.3.6.3-21           0.3.6.3-22
                    haskell-fsnotify           0.3.0.1-55           0.3.0.1-56
                      haskell-gnuidn            0.2.2-118            0.2.2-119
                      haskell-hakyll          4.12.5.2-67          4.12.5.2-68
                 haskell-hjsonschema            1.9.0-248            1.9.0-249
                   haskell-hspec-wai             0.9.2-57             0.9.2-58
              haskell-hspec-wai-json             0.9.2-65             0.9.2-66
                        haskell-http         4000.3.14-17         4000.3.14-18
                haskell-http-conduit           2.3.7.1-48           2.3.7.1-49
               haskell-http-download            0.1.0.0-4            0.1.0.0-5
                haskell-http-streams          0.8.6.1-130          0.8.6.1-132
                   haskell-js-jquery            3.3.1-261            3.3.1-262
                haskell-monad-logger            0.3.30-71            0.3.30-72
                    haskell-mustache            2.3.0-212            2.3.0-213
       haskell-network-protocol-xmpp            0.4.8-130            0.4.8-131
                      haskell-pantry            0.1.1.1-6            0.1.1.1-7
                     haskell-path-io             1.4.2-35             1.4.2-36
                  haskell-persistent             2.10.0-2             2.10.0-3
               haskell-persistent-qq             2.9.1-50             2.9.1-51
           haskell-persistent-sqlite             2.10.4-3             2.10.4-4
         haskell-persistent-template              2.7.2-2              2.7.2-3
             haskell-persistent-test            2.0.3.0-2            2.0.3.0-3
                 haskell-rio-orphans            0.1.1.0-2            0.1.1.0-3
                     haskell-servant            0.16.1-13             0.16.2-1
              haskell-servant-server            0.16.1-36             0.16.2-1
             haskell-servant-swagger           1.1.7.1-14           1.1.7.1-15
                       haskell-shake            0.18.3-13            0.18.3-14
                      haskell-shelly             1.8.1-65             1.8.1-66
                   haskell-snap-core           1.0.4.0-27           1.0.4.0-28
                 haskell-snap-server           1.1.1.1-58           1.1.1.1-59
                      haskell-turtle            1.5.14-16            1.5.14-17
                 haskell-unix-compat              0.5.1-6              0.5.2-1
              haskell-wai-app-static           3.1.6.3-81           3.1.6.3-82
                   haskell-wai-extra             3.0.27-9            3.0.27-10
          haskell-wai-handler-launch          3.0.2.4-197          3.0.2.4-198
                  haskell-wai-logger             2.3.5-19             2.3.5-20
                        haskell-warp              3.3.0-2              3.3.0-3
                    haskell-warp-tls             3.2.7-11             3.2.7-12
                        haskell-wreq           0.5.3.2-64           0.5.3.2-65
                      haskell-xcffib              0.8.1-8              0.8.1-9
                       haskell-yesod            1.6.0-316            1.6.0-317
                  haskell-yesod-auth             1.6.7-36             1.6.7-37
                  haskell-yesod-core            1.6.14-67            1.6.14-68
               haskell-yesod-default            1.2.0-565            1.2.0-566
                  haskell-yesod-form             1.6.6-10             1.6.6-11
            haskell-yesod-persistent           1.6.0.2-68           1.6.0.2-69
                haskell-yesod-static          1.6.0.1-168          1.6.0.1-169
                  haskell-yesod-test           1.6.6.1-62           1.6.6.1-63
                             hindent              5.3.1-5              5.3.1-6
                         hledger-api             1.14-103             1.14-105
                          hledger-ui            1.14.2-57            1.14.2-58
                         hledger-web           1.14.1-114           1.14.1-115
                              hoogle          5.0.17.10-2          5.0.17.10-3
                               idris              1.3.2-4              1.3.2-5
                   npm-check-updates             3.1.20-1             3.1.21-1
                              pandoc             2.7.3-22             2.7.3-23
                     pandoc-citeproc            0.16.2-89            0.16.2-90
                     pandoc-crossref           0.3.4.1-71           0.3.4.1-72
                            parallel           20190422-1           20190722-1
                              parole              1.0.2-1              1.0.2-2
                           postgrest              6.0.0-4              6.0.0-5
                  python-marshmallow             2.19.5-1             2.20.0-1
                  python-mysqlclient              1.4.3-1              1.4.4-1
                      python-pysaml2              4.6.5-1              4.8.0-1
                          python-tox             3.12.1-1             3.13.2-1
                 python2-marshmallow             2.19.5-1             2.20.0-1
               python2-pycryptodomex              3.7.3-1                    -
                         python2-tox             3.12.1-1             3.13.2-1
                   ruby-power_assert              1.1.4-1              1.1.5-1
                          shellcheck              0.7.0-5              0.7.0-6
                               sigil             0.9.16-2             0.9.17-1
                               stack              2.1.3-6              2.1.3-7
                      tamarin-prover            1.4.1-126            1.4.1-127
                              xmobar            0.29.5-39            0.29.5-40
                   zathura-pdf-mupdf              0.3.4-2              0.3.5-1
             python-argparse-manpage                    -                1.1-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-11           2019-08-12
-------------------------------------------------------------------------------
                             linux44            4.4.188-1            4.4.189-1
                     linux44-headers            4.4.188-1            4.4.189-1
                             linux49            4.9.188-1            4.9.189-1
                     linux49-headers            4.9.188-1            4.9.189-1
                       linux53 5.3rc3.d0804.ge21a712-1 5.3rc4.d0811.gd45331b-1
               linux53-headers 5.3rc3.d0804.ge21a712-1 5.3rc4.d0811.gd45331b-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-11           2019-08-12
-------------------------------------------------------------------------------
                              man-db              2.8.5-2            2.8.6.1-1
                           man-pages               5.01-1               5.02-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-11           2019-08-12
-------------------------------------------------------------------------------
                            exo-gtk3             0.12.7-3             0.12.8-1
                     libxfce4ui-gtk3             4.13.7-2             4.14.1-1
                   libxfce4util-gtk3             4.13.5-1             4.14.0-1
                   linux44-acpi_call            1.1.0-125            1.1.0-126
                    linux44-bbswitch              0.8-125              0.8-126
                 linux44-broadcom-wl      6.30.223.271-95      6.30.223.271-96
                    linux44-catalyst    1:15.201.1151-125    1:15.201.1151-126
                 linux44-ndiswrapper               1.62-7               1.62-8
                      linux44-nvidia           1:430.40-3           1:430.40-4
                linux44-nvidia-390xx            390.129-3            390.129-4
                    linux44-nvidiabl             0.88-125             0.88-126
                       linux44-r8168           8.047.02-4           8.047.02-5
                   linux44-rt3562sta        2.4.1.1_r4-93        2.4.1.1_r4-94
                    linux44-tp_smapi               0.43-4               0.43-5
    linux44-virtualbox-guest-modules             6.0.10-4             6.0.10-5
     linux44-virtualbox-host-modules             6.0.10-4             6.0.10-5
                         linux44-zfs              0.8.1-5              0.8.1-6
                   linux49-acpi_call            1.1.0-136            1.1.0-137
                    linux49-bbswitch              0.8-136              0.8-137
                 linux49-broadcom-wl     6.30.223.271-136     6.30.223.271-137
                    linux49-catalyst    1:15.201.1151-136    1:15.201.1151-137
                 linux49-ndiswrapper               1.62-6               1.62-7
                      linux49-nvidia           1:430.40-2           1:430.40-3
                linux49-nvidia-340xx           340.107-55           340.107-56
                linux49-nvidia-390xx            390.129-2            390.129-3
                    linux49-nvidiabl             0.88-136             0.88-137
                       linux49-r8168           8.047.02-4           8.047.02-5
                   linux49-rt3562sta       2.4.1.1_r4-134       2.4.1.1_r4-135
                    linux49-tp_smapi               0.43-4               0.43-5
                 linux49-vhba-module           20190410-7           20190410-8
    linux49-virtualbox-guest-modules             6.0.10-3             6.0.10-4
     linux49-virtualbox-host-modules             6.0.10-3             6.0.10-4
                         linux49-zfs              0.8.1-5              0.8.1-6
                   linux53-acpi_call            1.1.0-0.3            1.1.0-0.5
                    linux53-bbswitch              0.8-0.3              0.8-0.5
                 linux53-broadcom-wl     6.30.223.271-0.3     6.30.223.271-0.5
                      linux53-nvidia         1:430.40-0.3         1:430.40-0.5
                linux53-nvidia-390xx          390.129-0.3          390.129-0.5
                    linux53-nvidiabl             0.88-0.3             0.88-0.5
                       linux53-r8168         8.047.02-0.3         8.047.02-0.5
                   linux53-rtl8723bu    4.3.9.3.13200-0.3    4.3.9.3.13200-0.5
                    linux53-tp_smapi             0.43-0.3             0.43-0.5
                 linux53-vhba-module         20190410-0.3         20190410-0.5
    linux53-virtualbox-guest-modules           6.0.10-0.3           6.0.10-0.5
     linux53-virtualbox-host-modules           6.0.10-0.3           6.0.10-0.5
                xfce4-appfinder-gtk3             4.13.3-1             4.13.5-1
                    xfce4-panel-gtk3             4.13.7-2             4.14.0-1
                  xfce4-session-gtk3             4.13.4-3             4.14.0-2
                 xfce4-settings-gtk3             4.13.8-3             4.14.0-1
                         xfconf-gtk3             4.13.8-1             4.14.0-1
                      xfdesktop-gtk3             4.13.6-2             4.14.1-1
                          xfwm4-gtk3             4.13.4-2             4.14.0-1
                   libreoffice-fresh                    -              6.3.0-0
                libreoffice-fresh-af                    -              6.3.0-0
                libreoffice-fresh-am                    -              6.3.0-0
                libreoffice-fresh-ar                    -              6.3.0-0
                libreoffice-fresh-as                    -              6.3.0-0
               libreoffice-fresh-ast                    -              6.3.0-0
                libreoffice-fresh-be                    -              6.3.0-0
                libreoffice-fresh-bg                    -              6.3.0-0
                libreoffice-fresh-bn                    -              6.3.0-0
             libreoffice-fresh-bn-in                    -              6.3.0-0
                libreoffice-fresh-bo                    -              6.3.0-0
                libreoffice-fresh-br                    -              6.3.0-0
               libreoffice-fresh-brx                    -              6.3.0-0
                libreoffice-fresh-bs                    -              6.3.0-0
                libreoffice-fresh-ca                    -              6.3.0-0
       libreoffice-fresh-ca-valencia                    -              6.3.0-0
                libreoffice-fresh-cs                    -              6.3.0-0
                libreoffice-fresh-cy                    -              6.3.0-0
                libreoffice-fresh-da                    -              6.3.0-0
                libreoffice-fresh-de                    -              6.3.0-0
               libreoffice-fresh-dgo                    -              6.3.0-0
                libreoffice-fresh-dz                    -              6.3.0-0
                libreoffice-fresh-el                    -              6.3.0-0
             libreoffice-fresh-en-gb                    -              6.3.0-0
             libreoffice-fresh-en-za                    -              6.3.0-0
                libreoffice-fresh-eo                    -              6.3.0-0
                libreoffice-fresh-es                    -              6.3.0-0
                libreoffice-fresh-et                    -              6.3.0-0
                libreoffice-fresh-eu                    -              6.3.0-0
                libreoffice-fresh-fa                    -              6.3.0-0
                libreoffice-fresh-fi                    -              6.3.0-0
                libreoffice-fresh-fr                    -              6.3.0-0
                libreoffice-fresh-ga                    -              6.3.0-0
                libreoffice-fresh-gd                    -              6.3.0-0
                libreoffice-fresh-gl                    -              6.3.0-0
                libreoffice-fresh-gu                    -              6.3.0-0
                libreoffice-fresh-he                    -              6.3.0-0
                libreoffice-fresh-hi                    -              6.3.0-0
                libreoffice-fresh-hr                    -              6.3.0-0
                libreoffice-fresh-hu                    -              6.3.0-0
                libreoffice-fresh-id                    -              6.3.0-0
                libreoffice-fresh-is                    -              6.3.0-0
                libreoffice-fresh-it                    -              6.3.0-0
                libreoffice-fresh-ja                    -              6.3.0-0
                libreoffice-fresh-ka                    -              6.3.0-0
                libreoffice-fresh-kk                    -              6.3.0-0
                libreoffice-fresh-km                    -              6.3.0-0
          libreoffice-fresh-kmr-latn                    -              6.3.0-0
                libreoffice-fresh-kn                    -              6.3.0-0
                libreoffice-fresh-ko                    -              6.3.0-0
               libreoffice-fresh-kok                    -              6.3.0-0
                libreoffice-fresh-ks                    -              6.3.0-0
                libreoffice-fresh-lb                    -              6.3.0-0
                libreoffice-fresh-lo                    -              6.3.0-0
                libreoffice-fresh-lt                    -              6.3.0-0
                libreoffice-fresh-lv                    -              6.3.0-0
               libreoffice-fresh-mai                    -              6.3.0-0
                libreoffice-fresh-mk                    -              6.3.0-0
                libreoffice-fresh-ml                    -              6.3.0-0
                libreoffice-fresh-mn                    -              6.3.0-0
               libreoffice-fresh-mni                    -              6.3.0-0
                libreoffice-fresh-mr                    -              6.3.0-0
                libreoffice-fresh-my                    -              6.3.0-0
                libreoffice-fresh-nb                    -              6.3.0-0
                libreoffice-fresh-ne                    -              6.3.0-0
                libreoffice-fresh-nl                    -              6.3.0-0
                libreoffice-fresh-nn                    -              6.3.0-0
                libreoffice-fresh-nr                    -              6.3.0-0
               libreoffice-fresh-nso                    -              6.3.0-0
                libreoffice-fresh-oc                    -              6.3.0-0
                libreoffice-fresh-om                    -              6.3.0-0
                libreoffice-fresh-or                    -              6.3.0-0
             libreoffice-fresh-pa-in                    -              6.3.0-0
                libreoffice-fresh-pl                    -              6.3.0-0
                libreoffice-fresh-pt                    -              6.3.0-0
             libreoffice-fresh-pt-br                    -              6.3.0-0
                libreoffice-fresh-ro                    -              6.3.0-0
                libreoffice-fresh-ru                    -              6.3.0-0
                libreoffice-fresh-rw                    -              6.3.0-0
             libreoffice-fresh-sa-in                    -              6.3.0-0
               libreoffice-fresh-sat                    -              6.3.0-0
                libreoffice-fresh-sd                    -              6.3.0-0
               libreoffice-fresh-sdk                    -              6.3.0-0
                libreoffice-fresh-si                    -              6.3.0-0
               libreoffice-fresh-sid                    -              6.3.0-0
                libreoffice-fresh-sk                    -              6.3.0-0
                libreoffice-fresh-sl                    -              6.3.0-0
                libreoffice-fresh-sq                    -              6.3.0-0
                libreoffice-fresh-sr                    -              6.3.0-0
           libreoffice-fresh-sr-latn                    -              6.3.0-0
                libreoffice-fresh-ss                    -              6.3.0-0
                libreoffice-fresh-st                    -              6.3.0-0
                libreoffice-fresh-sv                    -              6.3.0-0
             libreoffice-fresh-sw-tz                    -              6.3.0-0
                libreoffice-fresh-ta                    -              6.3.0-0
                libreoffice-fresh-te                    -              6.3.0-0
                libreoffice-fresh-tg                    -              6.3.0-0
                libreoffice-fresh-th                    -              6.3.0-0
                libreoffice-fresh-tn                    -              6.3.0-0
                libreoffice-fresh-tr                    -              6.3.0-0
                libreoffice-fresh-ts                    -              6.3.0-0
                libreoffice-fresh-tt                    -              6.3.0-0
                libreoffice-fresh-ug                    -              6.3.0-0
                libreoffice-fresh-uk                    -              6.3.0-0
                libreoffice-fresh-uz                    -              6.3.0-0
                libreoffice-fresh-ve                    -              6.3.0-0
                libreoffice-fresh-vi                    -              6.3.0-0
                libreoffice-fresh-xh                    -              6.3.0-0
             libreoffice-fresh-zh-cn                    -              6.3.0-0
             libreoffice-fresh-zh-tw                    -              6.3.0-0
                libreoffice-fresh-zu                    -              6.3.0-0


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-11           2019-08-12
-------------------------------------------------------------------------------
                                 exo             0.12.7-1             0.12.8-1
                     gtk-xfce-engine             2.10.1-2                    -
                            libinput             1.13.4-1             1.14.0-1
                          libxfce4ui             4.13.7-1             4.14.1-2
                        libxfce4util             4.13.5-1             4.14.0-1
                            mousepad              0.4.2-1              0.4.2-2
                           pgbouncer              1.9.0-2             1.10.0-1
                         python-lxml              4.4.0-1              4.4.1-1
                    python-lxml-docs              4.4.0-1              4.4.1-1
            python-prometheus_client              0.6.0-1              0.7.1-1
                python2-configparser              3.7.4-1              3.8.1-1
                        python2-lxml              4.4.0-1              4.4.1-1
           python2-prometheus_client              0.6.0-1                    -
                           ristretto             0.10.0-1             0.10.0-2
                              thunar              1.8.8-1              1.8.9-2
                       thunar-volman              0.9.4-1              0.9.5-2
                             tumbler              0.2.6-1              0.2.7-1
        xf86-video-intel 1:2.99.917+865+g60022507-1 1:2.99.917+870+g6f4972d5-1
                     xfce4-appfinder             4.12.0-5             4.14.0-1
                xfce4-clipman-plugin              1.4.3-1              1.4.3-2
               xfce4-datetime-plugin              0.7.1-1              0.8.0-1
                     xfce4-dev-tools             4.13.0-1             4.14.0-1
                 xfce4-genmon-plugin              4.0.1-1              4.0.2-1
                  xfce4-notes-plugin              1.8.1-3              1.8.1-4
                       xfce4-notifyd              0.4.4-1              0.4.4-2
                         xfce4-panel             4.12.2-1             4.14.0-1
                 xfce4-power-manager              1.6.4-1              1.6.5-2
             xfce4-pulseaudio-plugin              0.4.1-1              0.4.2-2
                   xfce4-screensaver              0.1.7-1              0.1.8-2
                       xfce4-session            4.12.1-11             4.14.0-2
                      xfce4-settings             4.12.4-2             4.14.0-1
                      xfce4-terminal              0.8.8-1              0.8.8-2
                    xfce4-xkb-plugin              0.8.1-1              0.8.1-2
                              xfconf             4.12.1-7             4.14.1-1
                           xfdesktop             4.13.6-1             4.14.1-2
                               xfwm4             4.12.5-1             4.14.0-1
                         389-ds-base                    -            1.4.1.6-3
                       python-lib389                    -              1.0.4-2

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0
voters

Check if your mirror has already synced:

Posts: 43

Participants: 21

Read full topic


Full Story (EN):More …
Prevod Srpski:Prevod teksta (SR)
Prevod Hrvatski:Prevod teksta (HR)
Source:https://manjaro.github.io/